Exchange 2016 – 4096 (0x1000) is an invalid culture identifier

Für einen Kunden habe ich eine Exchange 2016 Organisation mit drei Exchange Servern aufgebaut.

Auf den Windows 10 Computern bekamen aber alle Benutzer folgende Fehlermeldung, sobald Sie OWA mit IE oder Edge öffnen wollten:

Auf dem betroffenen Exchange 2016 Server (CU6 und CU7) kam jeweils folgende Fehlermeldung im Systemprotokoll:

MSExchange Front End HTTP Proxy - EventID 1003

[Owa] An internal server error occurred. The unhandled exception was: System.Globalization.CultureNotFoundException: Culture is not supported.
 Parameter name: culture
 4096 (0x1000) is an invalid culture identifier.
    at System.Globalization.CultureInfo.InitializeFromCultureId(Int32 culture, Boolean useUserOverride)
    at Microsoft.Exchange.Net.ClientCultures.GetCultureInfoInstance(Int32 lcid)
    at Microsoft.Exchange.Net.ClientCultures.GetBrowserDefaultCulture(HttpRequestBase httpRequest)
    at Microsoft.Exchange.Clients.Owa.Core.OwaPage.InitializeCulture()
    at ASP.auth_errorfe_aspx.__BuildControlTree(auth_errorfe_aspx __ctrl)
    at ASP.auth_errorfe_aspx.FrameworkInitialize()
    at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
    at System.Web.UI.Page.ProcessRequest()
    at System.Web.UI.Page.ProcessRequest(HttpContext context)
    at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
    at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

Interessanterweise kam die Meldung aber nur beim Zugriff auf die Exchange 2016 Server die auf Windows 2016 Server installiert waren. Der Zugriff auf den Exchange 2016, welcher auf Windows 2012 R2 installiert, war funktionierte einwandfrei.

Auch der Zugriff von externen Windows 10 Computern oder mit Firefox oder Chrome funktionierte einwandfrei.

Versucht wurde:

  • Installation aller aktueller Windows Updates
  • Umstellen der Mailbox-Default Sprache der betroffen User
  • Update der Exchange Server auf CU7
  • Update Windows von 1706 auf 1709

Ohne Verbesserung.

Bei der weiteren Fehlersuche fiel mir auf, dass im Windows 10 eine sehr merkwürdige Sprachauswahl English (en-DE) stand:

Lösung:

Nach der Korrektur der Sprachauswahl trat der Fehler nicht mehr auf. Interessanterweise kann man nachträglich diese Spracheauswahl auch nicht mehr auswählen:

Ursachenforschung:

Bei der Installation der Windows 10 Rechner wurde immer eine englische Evaluations ISO von Windows 10 genommen, als Tastatur aber Deutsch und als Region Deutschland ausgewählt. Somit kam “English (de-EN)” zustande.

Laut Microsoft (Quelle https://msdn.microsoft.com/en-us/library/ee825488(v=cs.20).aspx) gibt es diese “Culture” aber gar nicht.

Wieso kommt bei Windows Server 2016 eine Fehlermeldung aber bei Windows Server 2012 R2 nicht?

Die Powershell Abfrage system.Globalization.CultureInfo]::GetCultures(‘AllCultures’)  ergibt beim Windows 2016 Server:

D.h. diese Culture-Auswahl ist bekannt, ergibt aber 4096

Bei einem Windows 2012 R2 Server fehlt diese:

Fazit

Meiner Meinung nach handelt es sich also um einen Bug im Windows 1706 und 1709, da eine scheinbar ungültige Sprachkombination English (en-DE) im System eingetragen wird. Diese wird dann von IE und vom Edge an den OWA übertragen,  der damit dann aber nicht anzufangen weiss. Ergo Fehlermeldung.

Auf einem Windows 2012 R2 Server kommt es zu der Fehlermeldung nicht, da der Server diese Kombination nicht kennt und somit ignoriert.

 

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.